SNAC(8) | System Manager's Manual | SNAC(8) |
snac
— snac
administration
The snac
daemon processes messages from
other servers in the Fediverse using the ActivityPub protocol.
This is the admin manual. For user operation, see snac(1). For file and data formats, see snac(5).
snac
makes heavy use of hard links and
link reference counts for its work, so don't even think of using it on a
filesystem that doesn't support this feature. Most UNIX-like operating
systems (Linux, the BSDs, the old DEC Ultrix machine in your grandfather
basement, probably MacOS) support hard links on their native filesystems.
Don't do fancy things like moving the subdirectories to different
filesystems. Also, if you move your snac
installation to another server, do it with a tool that respect hard link
counts. Remember: snac
is a very UNIXy program that
loves hard links.
A C compiler must be installed in the system, as well as the
development headers and libraries for OpenSSL (or compatible) and curl. To
build snac
, run
make
And, after that, run as root
make install
Once snac
is properly installed on the
system, designate a directory where the server and user data are to be
stored. This directory must not exist yet. snac
must
always be run as a regular user; you can create one for it or use your own.
To initialize the data storage, execute
snac init $HOME/snac-data
A small set of questions will be asked regarding the installation,
specially the host name it will run under, the local network address and
port snac
will listen to, the optional path prefix
and possibly other things.
You can launch the snac
process by
running
snac httpd $HOME/snac-data
Use a web browser to connect to the specified address and port. You should see a greeting page.
Log messages are sent to the standard error stream. By default, only relevant information is written there. You can increase the debugging level by editing the 'dbglevel' field in the server.json file or by setting a numeric value between 0 and 3 to the DEBUG environment variable, see below.
If you operate a Linux systemd-enabled system, OpenBSD or FreeBSD, there are startup scripts and configuration data in the examples directory. For other operating systems, please read the appropriate documentation on how to install a daemon as a non-root service.
Sometimes, the data storage disk layout changes between versions.
If there is such a change, snac
will refuse to run
and require an upgrade. Do this by running
snac upgrade $HOME/snac-data
Take special care to execute this upgrade operation without any
snac
processes serving on the same folder. You can
break everything. I know this because Tyler knows this.
An http server with TLS and proxying support must already be
installed and configured. snac
runs as a daemon and
listens on a TCP/IP socket, preferrably on a local interface. It can serve
the full domain or only a directory. The http server must be configured to
route to the snac
socket all related traffic and
also the webfinger standard address. The Host header must be propagated. See
the examples below.
Users must be created from the command line. You can do it by running
snac adduser $HOME/snac-data
All needed data will be prompted for. There is no artificial limit on the number of users that can be created.
The server.json configuration file allows some behaviour tuning:
host
prefix
address
port
dbglevel
layout
queue_retry_max
queue_retry_minutes
max_timeline_entries
timeline_purge_days
local_purge_days
cssurls
disable_cache
disable_openbsd_security
snac
makes use of the
enhanced security functions unveil(2) and
pledge(2). Setting this to true disables their usage.
These functions limit severely what an intruder can do in case of a
security vulnerability, so only enable this option if something is very
broken.num_threads
snac
will use when processing connections. Values
lesser than 4 will be ignored.disable_email_notifications
disable_inbox_collection
show_instance_timeline
admin_email
admin_account
short_description
fastcgi
snac
will use the FastCGI
interface to communicate with the upper level http server, that must be
configured accordingly.disable_history
You must restart the server to make effective these changes.
If a file named greeting.html is present in the server base directory, it will be returned whenever the base URL of the server is requested. Fill it with whatever information about the instance you want to supply to people visiting the server, like sign up requirements, site policies and such. The special %userlist% mark in the file will cause the list of users in this instance to be inserted.
Users can change a bit of information about themselves from the web interface. See snac(1) for details. Further, every user can have a private CSS file in their static/style.css that will be served instead of the server-wide one. It's not modifiable from the web interface to avoid users shooting themselves in the foot by destroying everything.
From version 2.06, there is no longer a need to add a special cron job for purging old data, as this is managed internally.
These are the following activities and objects that
snac
supports:
The rest of activities and objects are dropped on input.
There is partial support for OrderedCollection objects in the /outbox (with the last 20 entries of the local timeline shown). No pagination is supported. Intentionally, the /followers and /following paths return empty lists.
User migration from different Fediverse instances is a pain in the
ass that has been implemented everywhere as a kludgy afterthought. There is
not much that can be done, other than importing the list of people you
follow to your new snac
account.
To do this, download the user's list of accounts being followed (in CSV format) from the Mastodon web interface and execute this:
awk -F, 'NR > 1 { print $1 }' /path/to/following_accounts.csv | \ xargs -n 1 snac follow $SNAC_BASEDIR $SNAC_USER
Full instances can be blocked. This operation must be done from the command-line tool. See snac(1).
snac
stores all the messages it receives
as JSON files, which are usually bloated and filled with redundant
information. Using a filesystem with file compression enabled (like btrfs or
zfs) will probably be a good choice to store the
snac
data storage into.
DEBUG
You want to install the snac
Fediverse
daemon in the host example.com, that is correctly configured with a valid
TLS certificate and running the nginx httpd server. The service will be
installed under the fedi location. Two users, walter
and jessie, will be hosted in the system. Their Fediverse presence addresses
will be
https://example.com/fedi/walter
and
https://example.com/fedi/jesse,
respectively. They will be known in the Fediverse as @walter@example.com and
@jesse@example.com. The snac
daemon will run as the
user snacusr in the system and listen to the localhost:8001 network socket.
All data will be stored in the
/home/snacusr/fedidata directory.
Log into the system as snacusr and execute:
snac init /home/snacusr/fedidata
Answer "example.com" to the host name question, "/fedi" to the path prefix question, "localhost" to the address and "8001" to the port.
Create the users
snac adduser /home/snacusr/fedidata walter snac adduser /home/snacusr/fedidata jesse
Answer the questions with reasonable values.
Execute the server:
snac httpd /home/snacusr/fedidata
Edit the nginx configuration and add the following snippet to the example.com server section:
# nginx configuration example # main web access point location /fedi { proxy_pass http://localhost:8001; proxy_set_header Host $http_host; } # webfinger location /.well-known/webfinger { proxy_pass http://localhost:8001; proxy_set_header Host $http_host; } # Mastodon API (entry points) location /api/v1/ { proxy_pass http://localhost:8001; proxy_set_header Host $http_host; } location /api/v2/ { proxy_pass http://localhost:8001; proxy_set_header Host $http_host; } # Mastodon API (OAuth support) location /oauth { proxy_pass http://localhost:8001; proxy_set_header Host $http_host; } # optional location /.well-known/nodeinfo { proxy_pass http://localhost:8001; proxy_set_header Host $http_host; }
Restart the nginx daemon and connect to https://example.com/fedi/walter. The empty, default screen will be shown. Enter the admin section with the credentials defined for this user. Search people, start following them, engage in arid discussions and generally enjoy the frustrating experience of Social Media.
This is an example of a similar configuration for the Apache2 web server:
# apache2 configuration example ProxyPreserveHost On # Main web access point <Location /social> ProxyPass http://127.0.0.1:8001/social </Location> # WebFinger <Location /.well-known/webfinger> ProxyPass http://127.0.0.1:8001/.well-known/webfinger </Location> # NodeInfo (optional) <Location /.well-known/nodeinfo> ProxyPass http://127.0.0.1:8001/.well-known/nodeinfo </Location> # Mastodon API (entry points) <Location /api/v1/> ProxyPass http://127.0.0.1:8001/api/v1/ </Location> <Location /api/v2/> ProxyPass http://127.0.0.1:8001/api/v2/ </Location> # Mastodon API (OAuth support) <Location /oauth> ProxyPass http://127.0.0.1:8001/oauth </Location>
Since version 2.43, snac
supports
communicating from / to the front end http server using the FastCGI
protocol. There is no special advantage in using this, only that some
servers allow for simpler configuration. For example, in the case of nginx,
you can replace the two 'proxy_pass' and 'proxy_set_header' lines in the
example above with just
fastcgi_pass localhost:8001;
The only thing to change on snac
size is
to the set 'fastcgi' value to true in
server.json.
Further, using the FastCGI interface allows a much simpler configuration under OpenBSD's native httpd, given that it's natively implemented there and you no longer need to configure the complicated relayd server. This is an example:
# OpenBSD httpd configuration example # other server configuration [...] location "/fedi*" { fastcgi socket tcp "127.0.0.1" 8001 } location "/.well-known/webfinger" { fastcgi socket tcp "127.0.0.1" 8001 } location "/oauth/*" { fastcgi socket tcp "127.0.0.1" 8001 } location "/api/v1/*" { fastcgi socket tcp "127.0.0.1" 8001 } location "/api/v2/*" { fastcgi socket tcp "127.0.0.1" 8001 } location "/.well-known/nodeinfo" { fastcgi socket tcp "127.0.0.1" 8001 }
grunfink @grunfink@comam.es
See the LICENSE file for details.
JSON files are fragile when modified by hand. Take care.
January 31, 2025 | Debian |